Nachhilfe

 

 

 

Startseite

Dienstleistungen

Software

Datenschutz

Impressum

 

 

 

 

 

 

 

Excel Spezielle Formelsammlung 09g

 

Umgebungsbezogene Formeln für die Programmierung

 

In den Beispielen findet die Zelle C7 Verwendung.

Zusätzlich wird Zelle C8 mit einbezogen, wenn es um zwei Parameter geht.

Fließen drei Werte in die Berechnungen mit ein, wird Zelle C9 dabei berücksichtigt.

 

 

Bereiche

 

Bedingte Summen

Spezielle Formeln (Umgebungsbezug)

 

 

Bedingte Summen

 

Die Basisdaten befinden sich im Bereich $B$3:$D$12.

Kriterien können in den Zellen G3, G4 und G5 eingetragen werden.

Die Summe der betreffenden Ausgaben soll in Zelle G7 angezeigt werden.

 

Beispiel 01

 

 

A

B

C

D

E

F

G

H

1

 

 

 

 

 

 

 

 

2

 

Datum

Ausgabeart

Betrag

 

 

 

 

3

 

05.05.2021

Taxi

32,10 €

 

Datum

 

 

4

 

06.05.2021

Büromaterial

4,99 €

 

Ausgabeart

 

 

5

 

07.05.2021

Adapter

15,00 €

 

Betrag

 

 

6

 

08.05.2021

Werbung

33,90 €

 

 

 

 

7

 

09.05.2021

Büromaterial

2,19 €

 

Summe

189,87 €

 

8

 

10.05.2021

Taxi

25,70 €

 

 

 

 

9

 

11.05.2021

Taschenrechner

8,79 €

 

 

 

 

10

 

12.05.2021

Büromaterial

14,10 €

 

 

 

 

11

 

13.05.2021

Taxi

19,20 €

 

 

 

 

12

 

14.05.2021

Werbung

33,90 €

 

 

 

 

13

 

 

 

 

 

 

 

 

14

 

 

 

 

 

 

 

 

15

 

 

 

 

 

 

 

 

 

Es wurden keine Kriterien eingetragen.

Die Summe aller Ausgaben ist 189,87 €.

 

Formel in Zelle $G$7 (gelb):

 

=SUMMEWENNS(D3:D12;B3:B12;WENN(G3="";"<>""";G3);C3:C12;WENN(G4="";"<>""";G4);D3:D12;WENN(G5="";"<>""";G5))

 

Der Summenbereich ist D3:D12.

 

 

Beispiel 02

 

 

A

B

C

D

E

F

G

H

1

 

 

 

 

 

 

 

 

2

 

Datum

Ausgabeart

Betrag

 

 

 

 

3

 

05.05.2021

Taxi

32,10 €

 

Datum

>8.5.2021 

 

4

 

06.05.2021

Büromaterial

4,99 €

 

Ausgabeart

 

 

5

 

07.05.2021

Adapter

15,00 €

 

Betrag

 

 

6

 

08.05.2021

Werbung

33,90 €

 

 

 

 

7

 

09.05.2021

Büromaterial

2,19 €

 

Summe

103,88 €

 

8

 

10.05.2021

Taxi

25,70 €

 

 

 

 

9

 

11.05.2021

Taschenrechner

8,79 €

 

 

 

 

10

 

12.05.2021

Büromaterial

14,10 €

 

 

 

 

11

 

13.05.2021

Taxi

19,20 €

 

 

 

 

12

 

14.05.2021

Werbung

33,90 €

 

 

 

 

13

 

 

 

 

 

 

 

 

14

 

 

 

 

 

 

 

 

15

 

 

 

 

 

 

 

 

 

Datumsangaben können sich auf bestimmte Tage oder auch auf Datumsbereiche beziehen.

Die Zeichen kleiner (<), kleiner gleich (<=), gleich (=), größer gleich (>=), größer (>) und ungleich (<>) sind einsetzbar.

 

 

Beispiel 03

 

 

A

B

C

D

E

F

G

H

1

 

 

 

 

 

 

 

 

2

 

Datum

Ausgabeart

Betrag

 

 

 

 

3

 

05.05.2021

Taxi

32,10 €

 

Datum

 

 

4

 

06.05.2021

Büromaterial

4,99 €

 

Ausgabeart

Taxi 

 

5

 

07.05.2021

Adapter

15,00 €

 

Betrag

 

 

6

 

08.05.2021

Werbung

33,90 €

 

 

 

 

7

 

09.05.2021

Büromaterial

2,19 €

 

Summe

77,00 €

 

8

 

10.05.2021

Taxi

25,70 €

 

 

 

 

9

 

11.05.2021

Taschenrechner

8,79 €

 

 

 

 

10

 

12.05.2021

Büromaterial

14,10 €

 

 

 

 

11

 

13.05.2021

Taxi

19,20 €

 

 

 

 

12

 

14.05.2021

Werbung

33,90 €

 

 

 

 

13

 

 

 

 

 

 

 

 

14

 

 

 

 

 

 

 

 

15

 

 

 

 

 

 

 

 

 

Bei Textvariablen (hier die Art der Ausgabe) können auch Platzhalter genutzt werden.

„Büro*“ summiert Büromaterial, Bürobedarf, Büroeinrichtung und ähnliche.

Bei Eingabe von „Ta*“ würde auch der Taschenrechner im obigen Beispiel einbezogen.

Dann würde sich als Summe in Zelle $G$7 ein Betrag von 85,79 € ergeben.

 

 

Beispiel 04

 

 

A

B

C

D

E

F

G

H

1

 

 

 

 

 

 

 

 

2

 

Datum

Ausgabeart

Betrag

 

 

 

 

3

 

05.05.2021

Taxi

32,10 €

 

Datum

 

 

4

 

06.05.2021

Büromaterial

4,99 €

 

Ausgabeart

 

 

5

 

07.05.2021

Adapter

15,00 €

 

Betrag

33,90 €

 

6

 

08.05.2021

Werbung

33,90 €

 

 

 

 

7

 

09.05.2021

Büromaterial

2,19 €

 

Summe

67,80 €

 

8

 

10.05.2021

Taxi

25,70 €

 

 

 

 

9

 

11.05.2021

Taschenrechner

8,79 €

 

 

 

 

10

 

12.05.2021

Büromaterial

14,10 €

 

 

 

 

11

 

13.05.2021

Taxi

19,20 €

 

 

 

 

12

 

14.05.2021

Werbung

33,90 €

 

 

 

 

13

 

 

 

 

 

 

 

 

14

 

 

 

 

 

 

 

 

15

 

 

 

 

 

 

 

 

 

Der Betrag von 33,90 € wurde zweimal gelistet.

In beiden Fällen war die Ausgabeart „Werbung“.

 

 

Beispiel 05

 

Ausgaben vor dem 14ten.

Die nicht „Werbung“ sind.

Und über einem Betrag von 5,00 € liegen.

 

 

A

B

C

D

E

F

G

H

1

 

 

 

 

 

 

 

 

2

 

Datum

Ausgabeart

Betrag

 

 

 

 

3

 

05.05.2021

Taxi

32,10 €

 

Datum

<14.5.2021 

 

4

 

06.05.2021

Büromaterial

4,99 €

 

Ausgabeart

<>Werbung 

 

5

 

07.05.2021

Adapter

15,00 €

 

Betrag

>5 

 

6

 

08.05.2021

Werbung

33,90 €

 

 

 

 

7

 

09.05.2021

Büromaterial

2,19 €

 

Summe

114,89 €

 

8

 

10.05.2021

Taxi

25,70 €

 

 

 

 

9

 

11.05.2021

Taschenrechner

8,79 €

 

 

 

 

10

 

12.05.2021

Büromaterial

14,10 €

 

 

 

 

11

 

13.05.2021

Taxi

19,20 €

 

 

 

 

12

 

14.05.2021

Werbung

33,90 €

 

 

 

 

13

 

 

 

 

 

 

 

 

14

 

 

 

 

 

 

 

 

15

 

 

 

 

 

 

 

 

 

 

Die Formel in Zelle $G$7 (gelb):

 

=SUMMEWENNS(D3:D12;B3:B12;WENN(G3="";"<>""";G3);C3:C12;WENN(G4="";"<>""";G4);D3:D12;WENN(G5="";"<>""";G5))

 

beinhaltet eine Kombination von drei aufeinanderfolgenden Anführungszeichen (""").

Die Erklärung dafür ist, dass ohne eine bestimmte Eingabe in den Zellen G3, G4 und G5

nur abgeglichen werden soll, dass die entsprechenden Bereiche nicht leer, also <>"", sind.

Da dieser Ausdruck in Anführungszeichen erscheint, also "<>""", erhält man die angegebene Formel.

 

Bereiche