Nachhilfe

 

 

 

Startseite

Dienstleistungen

Software

Datenschutz

Impressum

 

 

 

 

 

 

 

Excel Spezielle Formelsammlung 09e

 

Umgebungsbezogene Formeln für die Programmierung

 

In den Beispielen findet die Zelle C7 Verwendung.

Zusätzlich wird Zelle C8 mit einbezogen, wenn es um zwei Parameter geht.

Fließen drei Werte in die Berechnungen mit ein, wird Zelle C9 dabei berücksichtigt.

 

 

Bereiche

 

Ein Datenfeld schließen

Spezielle Formeln (Umgebungsbezug)

 

 

Ein Datenfeld schließen

 

Basierend auf der datentypübergreifenden Suche.

 

Beispiel

 

Zunächst wird die Eingabe aus Zelle $B$2 in einen passenden Suchbegriff (Zelle $E$2) umgewandelt.

Die folgende Funktion findet Verwendung:

 

=WECHSELN(WENN(B2="";"*";SÄUBERN(GLÄTTEN(KLEIN(VERKETTEN("*";B2)))));" ";"")

 

Wenn B2 leer ist, wird ein Suchbegriff erzeugt, der immer in der Liste gefunden werden kann.

Im Beispiel ist dies *.

 

 

A

B

C

D

E

F

1

 

 

 

 

 

 

2

 

 

 

*

 

3

 

Eingabe

 

 

Suchbegriff

 

4

 

 

 

 

 

 

5

 

 

 

 

 

 

6

 

 

 

 

 

 

7

 

 

 

 

 

 

8

 

 

 

 

 

 

9

 

Datum

Uhrzeit

Name

 

 

10

 

 

 

 

 

 

11

 

10.08.2019

08:30

H. Schmidt

 

 

12

 

10.08.2019

10:00

H. Schmidt

 

 

13

 

10.08.2019

12:00

A. Hansen

 

 

14

 

11.08.2019

08:30

E. Roth

 

 

15

 

11.08.2019

10:00

E. Roth

 

 

16

 

11.08.2019

12:00

P. Larsson

 

 

17

 

12.08.2019

08:30

A. Hansen

 

 

18

 

12.08.2019

10:00

H. Schmidt

 

 

19

 

12.08.2019

12:00

A. Hansen

 

 

20

 

 

 

 

 

 

 

Es folgt die zeilenweise Verkettung von Datum, Uhrzeit und Name.

 

In Zelle E10:

 

=WECHSELN(SÄUBERN(GLÄTTEN(KLEIN(VERKETTEN(WENN(B10="";"";TEXT(B10;"TT.MM.JJJJ"));WENN(C10="";"";TEXT(C10;"hh:mm"));WENN(D10="";"";D10)))));" ";"")

 

In Zelle E11:

 

=WECHSELN(SÄUBERN(GLÄTTEN(KLEIN(VERKETTEN(WENN(B11="";"";TEXT(B11;"TT.MM.JJJJ"));WENN(C11="";"";TEXT(C11;"hh:mm"));WENN(D11="";"";D11)))));" ";"")

 

 

A

B

C

D

E

F

1

 

 

 

 

 

 

2

 

 

 

*

 

3

 

Eingabe

 

 

Suchbegriff

 

4

 

 

 

 

 

 

5

 

 

 

 

 

 

6

 

 

 

 

 

 

7

 

 

 

 

 

 

8

 

 

 

 

 

 

9

 

Datum

Uhrzeit

Name

Verkettung

 

10

 

 

 

 

 

 

11

 

10.08.2019

08:30

H. Schmidt

10.08.201908:30h.schmidt

 

12

 

10.08.2019

10:00

H. Schmidt

10.08.201910:00h.schmidt

 

13

 

10.08.2019

12:00

A. Hansen

10.08.201912:00a.hansen

 

14

 

11.08.2019

08:30

E. Roth

11.08.201908:30e.roth

 

15

 

11.08.2019

10:00

E. Roth

11.08.201910:00e.roth

 

16

 

11.08.2019

12:00

P. Larsson

11.08.201912:00p.larsson

 

17

 

12.08.2019

08:30

A. Hansen

12.08.201908:30a.hansen

 

18

 

12.08.2019

10:00

H. Schmidt

12.08.201910:00h.schmidt

 

19

 

12.08.2019

12:00

A. Hansen

12.08.201912:00a.hansen

 

20

 

 

 

 

 

 

 

Anschließend werden die Positionen zugeordnet.

 

In Zelle F10:

 

=WENNFEHLER(MAX($F$9:$F9)+SUCHEN($E$2;E10);"")

 

In Zelle F11:

 

=WENNFEHLER(MAX($F$9:$F10)+SUCHEN($E$2;E11);"")

 

 

A

B

C

D

E

F

1

 

 

 

 

 

 

2

 

 

 

*

 

3

 

Eingabe

 

 

Suchbegriff

 

4

 

 

 

 

 

 

5

 

 

 

 

 

 

6

 

 

 

 

 

 

7

 

 

 

 

 

 

8

 

 

 

 

 

 

9

 

Datum

Uhrzeit

Name

Verkettung

Position

10

 

 

 

 

 

 

11

 

10.08.2019

08:30

H. Schmidt

1

12

 

10.08.2019

10:00

H. Schmidt

2

13

 

10.08.2019

12:00

A. Hansen

3

14

 

11.08.2019

08:30

E. Roth

4

15

 

11.08.2019

10:00

E. Roth

5

16

 

11.08.2019

12:00

P. Larsson

6

17

 

12.08.2019

08:30

A. Hansen

7

18

 

12.08.2019

10:00

H. Schmidt

8

19

 

12.08.2019

12:00

A. Hansen

9

20

 

 

 

 

 

 

 

Die jeweiligen Datumsangaben werden übernommen.

 

In Zelle G10:

 

=WENNFEHLER(INDEX($B$10:$B$19;VERGLEICH(KKLEINSTE($F$10:$F$19;ZEILE()-9);$F$10:$F$19;0));"")

 

In Zelle G11:

 

=WENNFEHLER(INDEX($B$10:$B$19;VERGLEICH(KKLEINSTE($F$10:$F$19;ZEILE()-9);$F$10:$F$19;0));"")

 

 

A

B

C

D

E

F

G

H

1

 

 

 

 

 

 

 

 

2

 

 

 

*

 

 

 

3

 

Eingabe

 

 

Suchbegriff

 

 

 

4

 

 

 

 

 

 

 

 

5

 

 

 

 

 

 

 

 

6

 

 

 

 

 

 

 

 

7

 

 

 

 

 

 

 

 

8

 

 

 

 

 

 

 

 

9

 

Datum

Uhrzeit

Name

Verkettung

Position

Datum

 

10

 

 

 

 

 

 

10.08.2019

 

11

 

10.08.2019

08:30

H. Schmidt

1

10.08.2019

 

12

 

10.08.2019

10:00

H. Schmidt

2

10.08.2019

 

13

 

10.08.2019

12:00

A. Hansen

3

11.08.2019

 

14

 

11.08.2019

08:30

E. Roth

4

11.08.2019

 

15

 

11.08.2019

10:00

E. Roth

5

11.08.2019

 

16

 

11.08.2019

12:00

P. Larsson

6

12.08.2019

 

17

 

12.08.2019

08:30

A. Hansen

7

12.08.2019

 

18

 

12.08.2019

10:00

H. Schmidt

8

12.08.2019

 

19

 

12.08.2019

12:00

A. Hansen

9

 

 

20

 

 

 

 

 

 

 

 

 

Ebenso die Uhrzeit.

 

In Zelle H10:

 

=WENNFEHLER(INDEX($C$10:$C$19;VERGLEICH(KKLEINSTE($F$10:$F$19;ZEILE()-9);$F$10:$F$19;0));"")

 

In Zelle H11:

 

=WENNFEHLER(INDEX($C$10:$C$19;VERGLEICH(KKLEINSTE($F$10:$F$19;ZEILE()-9);$F$10:$F$19;0));"")

 

 

A

B

C

D

E

F

G

H

I

1

 

 

 

 

 

 

 

 

 

2

 

 

 

*

 

 

 

 

3

 

Eingabe

 

 

Suchbegriff

 

 

 

 

4

 

 

 

 

 

 

 

 

 

5

 

 

 

 

 

 

 

 

 

6

 

 

 

 

 

 

 

 

 

7

 

 

 

 

 

 

 

 

 

8

 

 

 

 

 

 

 

 

 

9

 

Datum

Uhrzeit

Name

Verkettung

Position

Datum

Uhrzeit

 

10

 

 

 

 

 

 

10.08.2019

8:30

 

11

 

10.08.2019

08:30

H. Schmidt

1

10.08.2019

10:00

 

12

 

10.08.2019

10:00

H. Schmidt

2

10.08.2019

12:00

 

13

 

10.08.2019

12:00

A. Hansen

3

11.08.2019

8:30

 

14

 

11.08.2019

08:30

E. Roth

4

11.08.2019

10:00

 

15

 

11.08.2019

10:00

E. Roth

5

11.08.2019

12:00

 

16

 

11.08.2019

12:00

P. Larsson

6

12.08.2019

8:30

 

17

 

12.08.2019

08:30

A. Hansen

7

12.08.2019

10:00

 

18

 

12.08.2019

10:00

H. Schmidt

8

12.08.2019

12:00

 

19

 

12.08.2019

12:00

A. Hansen

9

 

 

 

20

 

 

 

 

 

 

 

 

 

 

Und der Name.

 

In Zelle I10:

 

=WENNFEHLER(INDEX($D$10:$D$19;VERGLEICH(KKLEINSTE($F$10:$F$19;ZEILE()-9);$F$10:$F$19;0));"")

 

In Zelle I11:

 

=WENNFEHLER(INDEX($D$10:$D$19;VERGLEICH(KKLEINSTE($F$10:$F$19;ZEILE()-9);$F$10:$F$19;0));"")

 

 

A

B

C

D

E

F

G

H

I

1

 

 

 

 

 

 

 

 

 

2

 

 

 

*

 

 

 

 

3

 

Eingabe

 

 

Suchbegriff

 

 

 

 

4

 

 

 

 

 

 

 

 

 

5

 

 

 

 

 

 

 

 

 

6

 

 

 

 

 

 

 

 

 

7

 

 

 

 

 

 

 

 

 

8

 

 

 

 

 

 

 

 

 

9

 

Datum

Uhrzeit

Name

Verkettung

Position

Datum

Uhrzeit

Name

10

 

 

 

 

 

 

10.08.2019

8:30

H. Schmidt

11

 

10.08.2019

08:30

H. Schmidt

1

10.08.2019

10:00

H. Schmidt

12

 

10.08.2019

10:00

H. Schmidt

2

10.08.2019

12:00

A. Hansen

13

 

10.08.2019

12:00

A. Hansen

3

11.08.2019

8:30

E. Roth

14

 

11.08.2019

08:30

E. Roth

4

11.08.2019

10:00

E. Roth

15

 

11.08.2019

10:00

E. Roth

5

11.08.2019

12:00

P. Larsson

16

 

11.08.2019

12:00

P. Larsson

6

12.08.2019

8:30

A. Hansen

17

 

12.08.2019

08:30

A. Hansen

7

12.08.2019

10:00

H. Schmidt

18

 

12.08.2019

10:00

H. Schmidt

8

12.08.2019

12:00

A. Hansen

19

 

12.08.2019

12:00

A. Hansen

9

 

 

 

20

 

 

 

 

 

 

 

 

 

 

Bereiche