Nachhilfe

 

 

 

Startseite

Dienstleistungen

Software

Datenschutz

Impressum

 

 

 

 

 

 

 

Excel Spezielle Formelsammlung 09b

 

Umgebungsbezogene Formeln für die Programmierung

 

In den Beispielen findet die Zelle C7 Verwendung.

Zusätzlich wird Zelle C8 mit einbezogen, wenn es um zwei Parameter geht.

Fließen drei Werte in die Berechnungen mit ein, wird Zelle C9 dabei berücksichtigt.

 

 

Bereiche

 

Zahlen absteigend ordnen

Euro-Angaben absteigend ordnen

Zeitangaben absteigend ordnen

Datumsangaben absteigend ordnen

Text absteigend ordnen

Zeit mit Namen absteigend ordnen

Spezielle Formeln (Umgebungsbezug)

 

 

Zahlen absteigend ordnen

 

Die Funktion KGRÖSSTE findet Verwendung.

Duplikate werden berücksichtigt und Text wird ignoriert.

 

Beispiel

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENNFEHLER(KGRÖSSTE($C$1:$C$10;ZEILE());"")

4

2

1

""

3

3

4

""

3

4

 

""

1

5

3

""

 

6

 

""

 

7

 

""

 

8

3

""

 

9

 

""

 

10

Z

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Euro-Angaben absteigend ordnen

 

Die Funktion KGRÖSSTE findet Verwendung.

Duplikate werden berücksichtigt und Text wird ignoriert.

 

Beispiel

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENNFEHLER(KGRÖSSTE($C$1:$C$10;ZEILE());"")

22,60 €

2

nicht angegeben

""

12,99 €

3

 

""

-4,00 €

4

-4,00 €

""

-8,99 €

5

 

""

 

6

 

""

 

7

22,60 €

""

 

8

12,99 €

""

 

9

-8,99 €

""

 

10

 

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Zeitangaben absteigend ordnen

 

Die Funktion KGRÖSSTE findet Verwendung.

Duplikate werden berücksichtigt und Text wird ignoriert.

 

Beispiel

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENNFEHLER(KGRÖSSTE($C$1:$C$10;ZEILE());"")

01:51:22

2

 

""

01:25:27

3

01:25:27

""

01:01:12

4

01:01:12

""

00:59:01

5

00:57:24

""

00:57:24

6

00:59:01

""

 

7

01:51:22

""

 

8

 

""

 

9

 

""

 

10

 

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Datumsangaben absteigend ordnen

 

Die Funktion KGRÖSSTE findet Verwendung.

Duplikate werden berücksichtigt und Text wird ignoriert.

 

Beispiel

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENNFEHLER(KGRÖSSTE($C$1:$C$10;ZEILE());"")

03.10.2018

2

03.05.2017

""

06.06.2018

3

05.05.2017

""

01.06.2018

4

05.05.2017

""

04.11.2017

5

06.06.2018

""

05.05.2017

6

01.06.2018

""

05.05.2017

7

03.10.2018

""

03.05.2017

8

04.11.2017

""

 

9

 

""

 

10

 

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Text absteigend ordnen

 

Eine Kombination von Funktionen findet Verwendung.

Duplikate werden berücksichtigt und Zahlenangaben führen zu Fehlern.

 

Beispiel

 

Zunächst wird den Textdaten eine Positionsnummer zugeordnet.

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENN(C1="";"";ZÄHLENWENN($C$1:$C$10;VERKETTEN("<=";C1)))

 

2

Abend

=WENN(C2="";"";ZÄHLENWENN($C$1:$C$10;VERKETTEN("<=";C2)))

1

3

Circus

=WENN(C3="";"";ZÄHLENWENN($C$1:$C$10;VERKETTEN("<=";C3)))

3

4

Dach

""

4

5

Baum

""

2

6

Rat

""

5

7

Suche

""

6

8

 

""

 

9

 

""

 

10

 

""

 

 

Die Positionsnummern sind Zahlen, die absteigend geordnet werden.

Das zugehörige Textelement wird über INDEX und VERGLEICH gefunden.

 

 

C (Eingabebereich)

D (Positionsnummer)

E (Formel)

E (Ergebnis)

1

 

 

=WENNFEHLER(INDEX($C$1:$C$10;VERGLEICH(KGRÖSSTE($D$1:$D$10;ZEILE());$D$1:$D$10;0));"")

Suche

2

Abend

1

""

Rat

3

Circus

3

""

Dach

4

Dach

4

""

Circus

5

Baum

2

""

Baum

6

Rat

5

""

Abend

7

Suche

6

""

 

8

 

 

""

 

9

 

 

""

 

10

 

 

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Bereich der Positionsnummern ($D$1:$D$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Zeit mit Namen absteigend ordnen

 

Eine Kombination von Funktionen findet Verwendung.

 

Beispiel

 

Zunächst werden die Zeiten absteigend geordnet (E).

Der zugehörige Name wird über INDEX und VERGLEICH gefunden.

 

 

C (Eingabebereich 1)

D (Eingabebereich 2)

E (Ergebnis)

F (Formel)

F (Ergebnis)

1

 

 

01:51:22

=WENNFEHLER(INDEX($D$1:$D$10;VERGLEICH(E1;$C$1:$C$10;0));"")

Chris

2

 

 

01:25:27

=WENNFEHLER(INDEX($D$1:$D$10;VERGLEICH(E2;$C$1:$C$10;0));"")

Laura

3

01:25:27

Laura

01:01:12

=WENNFEHLER(INDEX($D$1:$D$10;VERGLEICH(E3;$C$1:$C$10;0));"")

Peter

4

01:01:12

Peter

00:59:01

""

Maria

5

00:57:24

Domenico

00:57:24

""

Domenico

6

00:59:01

Maria

 

""

 

7

01:51:22

Chris

 

""

 

8

 

 

 

""

 

9

 

 

 

""

 

10

 

 

 

""

 

 

Der Eingabebereich 1 ($C$1:$C$10) muss absolut adressiert sein.

Der Eingabebereich 2 ($D$1:$D$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche