Nachhilfe

 

 

 

Startseite

Dienstleistungen

Software

Datenschutz

Impressum

 

 

 

 

 

 

 

Excel Spezielle Formelsammlung 09a

 

Umgebungsbezogene Formeln für die Programmierung

 

In den Beispielen findet die Zelle C7 Verwendung.

Zusätzlich wird Zelle C8 mit einbezogen, wenn es um zwei Parameter geht.

Fließen drei Werte in die Berechnungen mit ein, wird Zelle C9 dabei berücksichtigt.

 

 

Bereiche

 

Zahlen aufsteigend ordnen

Euro-Angaben aufsteigend ordnen

Zeitangaben aufsteigend ordnen

Datumsangaben aufsteigend ordnen

Text aufsteigend ordnen

Zeit mit Namen aufsteigend ordnen

Spezielle Formeln (Umgebungsbezug)

 

 

Zahlen aufsteigend ordnen

 

Die Funktion KKLEINSTE findet Verwendung.

Duplikate werden berücksichtigt und Text wird ignoriert.

 

Beispiel

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENNFEHLER(KKLEINSTE($C$1:$C$10;ZEILE());"")

1

2

1

""

3

3

4

""

3

4

 

""

4

5

3

""

 

6

 

""

 

7

 

""

 

8

3

""

 

9

 

""

 

10

Z

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Euro-Angaben aufsteigend ordnen

 

Die Funktion KKLEINSTE findet Verwendung.

Duplikate werden berücksichtigt und Text wird ignoriert.

 

Beispiel

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENNFEHLER(KKLEINSTE($C$1:$C$10;ZEILE());"")

-8,99 €

2

nicht angegeben

""

-4,00 €

3

 

""

12,99 €

4

-4,00 €

""

22,60 €

5

 

""

 

6

 

""

 

7

22,60 €

""

 

8

12,99 €

""

 

9

-8,99 €

""

 

10

 

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Zeitangaben aufsteigend ordnen

 

Die Funktion KKLEINSTE findet Verwendung.

Duplikate werden berücksichtigt und Text wird ignoriert.

 

Beispiel

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENNFEHLER(KKLEINSTE($C$1:$C$10;ZEILE());"")

00:57:24

2

 

""

00:59:01

3

01:25:27

""

01:01:12

4

01:01:12

""

01:25:27

5

00:57:24

""

01:51:22

6

00:59:01

""

 

7

01:51:22

""

 

8

 

""

 

9

 

""

 

10

 

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Datumsangaben aufsteigend ordnen

 

Die Funktion KKLEINSTE findet Verwendung.

Duplikate werden berücksichtigt und Text wird ignoriert.

 

Beispiel

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENNFEHLER(KKLEINSTE($C$1:$C$10;ZEILE());"")

03.05.2017

2

03.05.2017

""

05.05.2017

3

05.05.2017

""

05.05.2017

4

05.05.2017

""

04.11.2017

5

06.06.2018

""

01.06.2018

6

01.06.2018

""

06.06.2018

7

03.10.2018

""

03.10.2018

8

04.11.2017

""

 

9

 

""

 

10

 

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Text aufsteigend ordnen

 

Eine Kombination von Funktionen findet Verwendung.

Duplikate werden berücksichtigt und Zahlenangaben führen zu Fehlern.

 

Beispiel

 

Zunächst wird den Textdaten eine Positionsnummer zugeordnet.

 

 

C (Eingabebereich)

D (Formel)

D (Ergebnis)

1

 

=WENN(C1="";"";ZÄHLENWENN($C$1:$C$10;VERKETTEN("<=";C1)))

 

2

Abend

=WENN(C2="";"";ZÄHLENWENN($C$1:$C$10;VERKETTEN("<=";C2)))

1

3

Circus

=WENN(C3="";"";ZÄHLENWENN($C$1:$C$10;VERKETTEN("<=";C3)))

3

4

Dach

""

4

5

Baum

""

2

6

Rat

""

5

7

Suche

""

6

8

 

""

 

9

 

""

 

10

 

""

 

 

Die Positionsnummern sind Zahlen, die aufsteigend geordnet werden.

Das zugehörige Textelement wird über INDEX und VERGLEICH gefunden.

 

 

C (Eingabebereich)

D (Positionsnummer)

E (Formel)

E (Ergebnis)

1

 

 

=WENNFEHLER(INDEX($C$1:$C$10;VERGLEICH(KKLEINSTE($D$1:$D$10;ZEILE());$D$1:$D$10;0));"")

Abend

2

Abend

1

""

Baum

3

Circus

3

""

Circus

4

Dach

4

""

Dach

5

Baum

2

""

Rat

6

Rat

5

""

Suche

7

Suche

6

""

 

8

 

 

""

 

9

 

 

""

 

10

 

 

""

 

 

Der Eingabebereich ($C$1:$C$10) muss absolut adressiert sein.

Der Bereich der Positionsnummern ($D$1:$D$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche

 

Zeit mit Namen aufsteigend ordnen

 

Eine Kombination von Funktionen findet Verwendung.

 

Beispiel

 

Zunächst werden die Zeiten aufsteigend geordnet (E).

Der zugehörige Name wird über INDEX und VERGLEICH gefunden.

 

 

C (Eingabebereich 1)

D (Eingabebereich 2)

E (Ergebnis)

F (Formel)

F (Ergebnis)

1

 

 

00:57:24

=WENNFEHLER(INDEX($D$1:$D$10;VERGLEICH(E1;$C$1:$C$10;0));"")

Domenico

2

 

 

00:59:01

=WENNFEHLER(INDEX($D$1:$D$10;VERGLEICH(E2;$C$1:$C$10;0));"")

Maria

3

01:25:27

Laura

01:01:12

=WENNFEHLER(INDEX($D$1:$D$10;VERGLEICH(E3;$C$1:$C$10;0));"")

Peter

4

01:01:12

Peter

01:25:27

""

Laura

5

00:57:24

Domenico

01:51:22

""

Chris

6

00:59:01

Maria

 

""

 

7

01:51:22

Chris

 

""

 

8

 

 

 

""

 

9

 

 

 

""

 

10

 

 

 

""

 

 

Der Eingabebereich 1 ($C$1:$C$10) muss absolut adressiert sein.

Der Eingabebereich 2 ($D$1:$D$10) muss absolut adressiert sein.

Der Formelbereich muss in Zeile 1 beginnen.

 

Bereiche