Nachhilfe

 

 

 

Startseite

Dienstleistungen

Software

Datenschutz

Impressum

 

 

 

 

 

 

 

Excel Spezielle Formelsammlung 04

 

Umgebungsbezogene Formeln für die Programmierung

 

In den Beispielen findet die Zelle C7 Verwendung.

Zusätzlich wird Zelle C8 mit einbezogen, wenn es um zwei Parameter geht.

Fließen drei Werte in die Berechnungen mit ein, wird Zelle C9 dabei berücksichtigt.

 

 

Bereiche

 

Arbeitsumgebung Excel Online

Arbeitsumgebung Excel-Datei mit Zoho

Arbeitsumgebung Zoho-Datei

Arbeitsumgebung Open Office

Arbeitsumgebung Libre Office

Arbeitsumgebung Google Spreadsheets

Excel Online vs. Excel Online Iframe

Excel Online und Excel Online Iframe Funktionalitätsunterschiede

Excel Online Iframe Detection

Spezielle Formeln (Umgebungsbezug)

 

 

Arbeitsumgebung Excel Online

 

Verschiedene Arbeitsumgebungen können die Ergebnisse von Formeln beeinflussen.

In den folgenden Beispielen sind die Unterschiede farblich hervorgehoben.

 

Formel

Excel Desktop (Beispiel)

Excel Online (Beispiel)

=ZELLE("dateiname";$A$1)

C:\Users\User1\Desktop\Folder1\Datenbank.xlsx

#WERT!

=ZELLE("typ";$A$1)

b

b

=INFO("VERZEICHNIS")

C:\Users\User1\Documents\

#WERT!

=INFO("DATEIENZAHL")

31

#WERT!

=INFO("SYSVERSION")

Windows (32-bit) NT 6.01

#WERT!

=INFO("BERECHNE")

Automatisch

#WERT!

=INFO("VERSION")

14.0

#WERT!

=INFO("SYSTEM")

pcdos

#WERT!

=DATWERT("1.1.2020")

43831

43831

=DELTA(1;1)

1

1

=ISTFEHLER("w"*1)

WAHR

WAHR

=N(WAHR)

1

1

=NICHT(FALSCH)

WAHR

WAHR

=REST(3;2)

1

1

=T("a")

a

a

=ZEICHEN(65)

A

A

=CODE("A")

65

65

 

Bereiche

 

Arbeitsumgebung Excel-Datei mit Zoho

 

Verschiedene Arbeitsumgebungen können die Ergebnisse von Formeln beeinflussen.

In den folgenden Beispielen sind die Unterschiede farblich hervorgehoben.

 

Formel

Excel Desktop (Beispiel)

Excel-Datei mit Zoho (Beispiel)

=ZELLE("dateiname";$A$1)

C:\Users\User1\Desktop\Folder1\Datenbank.xlsx

#VALUE!

=ZELLE("typ";$A$1)

b

#VALUE!

=INFO("VERZEICHNIS")

C:\Users\User1\Documents\

#NAME!

=INFO("DATEIENZAHL")

31

#NAME!

=INFO("SYSVERSION")

Windows (32-bit) NT 6.01

#NAME!

=INFO("BERECHNE")

Automatisch

#NAME!

=INFO("VERSION")

14.0

#NAME!

=INFO("SYSTEM")

pcdos

#NAME!

=DATWERT("1.1.2020")

43831

43831

=DELTA(1;1)

1

1

=ISTFEHLER("w"*1)

WAHR

TRUE

=N(WAHR)

1

1

=NICHT(FALSCH)

WAHR

TRUE

=REST(3;2)

1

1

=T("a")

a

a

=ZEICHEN(65)

A

A

=CODE("A")

65

65

 

Bereiche

 

Arbeitsumgebung Zoho-Datei

 

Verschiedene Arbeitsumgebungen können die Ergebnisse von Formeln beeinflussen.

In den folgenden Beispielen sind die Unterschiede farblich hervorgehoben.

 

Formel

Excel Desktop (Beispiel)

Zoho-Datei (Beispiel)

=ZELLE("dateiname";$A$1)

C:\Users\User1\Desktop\Folder1\Datenbank.xlsx

C:\Users\User1\Desktop\Folder1\Datenbank.xlsx

=ZELLE("typ";$A$1)

b

b

=INFO("VERZEICHNIS")

C:\Users\User1\Documents\

#NUM!

=INFO("DATEIENZAHL")

31

#NUM!

=INFO("SYSVERSION")

Windows (32-bit) NT 6.01

#NUM!

=INFO("BERECHNE")

Automatisch

#NUM!

=INFO("VERSION")

14.0

2c39ebcf06445232b79816ads8f7sa7e7d82ea8

=INFO("SYSTEM")

pcdos

LINUX

=DATWERT("1.1.2020")

43831

43831

=DELTA(1;1)

1

1

=ISTFEHLER("w"*1)

WAHR

1

=N(WAHR)

1

1

=NICHT(FALSCH)

WAHR

1

=REST(3;2)

1

1

=T("a")

a

a

=ZEICHEN(65)

A

A

=CODE("A")

65

65

 

Bereiche

 

Arbeitsumgebung Open Office

 

Verschiedene Arbeitsumgebungen können die Ergebnisse von Formeln beeinflussen.

In den folgenden Beispielen sind die Unterschiede farblich hervorgehoben.

 

Formel

Excel Desktop (Beispiel)

Open Office (Beispiel)

=ZELLE("dateiname";$A$1)

C:\Users\User1\Desktop\Folder1\Datenbank.xlsx

file:///C:/Users/.../Desktop/...et.xlsx'#$Excel offline

=ZELLE("typ";$A$1)

b

b

=INFO("VERZEICHNIS")

C:\Users\User1\Documents\

Err:502

=INFO("DATEIENZAHL")

31

Err:502

=INFO("SYSVERSION")

Windows (32-bit) NT 6.01

Err:502

=INFO("BERECHNE")

Automatisch

Err:502

=INFO("VERSION")

14.0

320m18(Build:9502)

=INFO("SYSTEM")

pcdos

WNT

=DATWERT("1.1.2020")

43831

43831

=DELTA(1;1)

1

1

=ISTFEHLER("w"*1)

WAHR

WAHR

=N(WAHR)

1

1

=NICHT(FALSCH)

WAHR

WAHR

=REST(3;2)

1

1

=T("a")

a

a

=ZEICHEN(65)

A

A

=CODE("A")

65

65

 

Bereiche

 

Arbeitsumgebung Libre Office

 

Verschiedene Arbeitsumgebungen können die Ergebnisse von Formeln beeinflussen.

In den folgenden Beispielen sind die Unterschiede farblich hervorgehoben.

 

Formel

Excel Desktop (Beispiel)

Libre Office (Beispiel)

=ZELLE("dateiname";$A$1)

C:\Users\User1\Desktop\Folder1\Datenbank.xlsx

C:\Users\User1\Desktop\Folder1\Datenbank.xlsx

=ZELLE("typ";$A$1)

b

b

=INFO("VERZEICHNIS")

C:\Users\User1\Documents\

Err:502

=INFO("DATEIENZAHL")

31

Err:502

=INFO("SYSVERSION")

Windows (32-bit) NT 6.01

Err:502

=INFO("BERECHNE")

Automatisch

Err:502

=INFO("VERSION")

14.0

1b798798sd348b492231e79s8d9sfsd89sd262b

=INFO("SYSTEM")

pcdos

WNT

=DATWERT("1.1.2020")

43831

43831

=DELTA(1;1)

1

1

=ISTFEHLER("w"*1)

WAHR

1

=N(WAHR)

1

1

=NICHT(FALSCH)

WAHR

1

=REST(3;2)

1

1

=T("a")

a

a

=ZEICHEN(65)

A

A

=CODE("A")

65

65

 

Bereiche

 

Arbeitsumgebung Google Spreadsheets

 

Verschiedene Arbeitsumgebungen können die Ergebnisse von Formeln beeinflussen.

In den folgenden Beispielen sind die Unterschiede farblich hervorgehoben.

 

Formel

Excel Desktop (Beispiel)

Google Spreadsheets (Beispiel)

=ZELLE("dateiname";$A$1)

C:\Users\User1\Desktop\Folder1\Datenbank.xlsx

#VALUE!

=ZELLE("typ";$A$1)

b

#VALUE!

=INFO("VERZEICHNIS")

C:\Users\User1\Documents\

#NAME?

=INFO("DATEIENZAHL")

31

#NAME?

=INFO("SYSVERSION")

Windows (32-bit) NT 6.01

#NAME?

=INFO("BERECHNE")

Automatisch

#NAME?

=INFO("VERSION")

14.0

#NAME?

=INFO("SYSTEM")

pcdos

#NAME?

=DATWERT("1.1.2020")

43831

43831

=DELTA(1;1)

1

1

=ISTFEHLER("w"*1)

WAHR

TRUE

=N(WAHR)

1

1

=NICHT(FALSCH)

WAHR

TRUE

=REST(3;2)

1

1

=T("a")

a

a

=ZEICHEN(65)

A

A

=CODE("A")

65

65

 

Bereiche

 

Excel Online vs. Excel Online Iframe

 

Excel Online und Excel Online Iframe nutzen teilweise voneinander abweichende Datenformate.

In den folgenden Beispielen sind die Unterschiede farblich hervorgehoben.

 

 

Excel Online

Excel Online

Excel Online Iframe

Excel Online Iframe

Datentyp

Format

Beispiel

Format

Beispiel

Zahl

Zahl

4

Zahl

15

Kommazahl

Kommazahl

8,25

Zahl mit Punkt

17.82

Uhrzeit

Uhrzeit

18:09

Uhrzeit

15:41

Währung

Kommazahl

45,70 €

Zahl mit Punkt

16.40 €

Datum

Tag.Monat.Jahr

17.10.2019

Monat/Tag/Jahr

1/4/2020

 

Bereiche

 

Excel Online und Excel Online Iframe Funktionalitätsunterschiede

 

Excel Online und Excel Online Iframe weisen Funktionalitätsunterschiede auf.

Diese betreffen sowohl Formelsprache und Trennzeichen, als auch das User Interface (UI).

 

Beispiel

Excel Online

Excel Online Iframe

Notiz

Uhrzeit (jetzt)

17:21

16:21

Eine Stunde zurück

Kopieren

Formeln, Werte, Formatierung, Transponierte

nur Werte

 

Einfügen

Formeln, Werte, Formatierung, Transponierte

funktioniert nicht

 

Formelsprache

Deutsch

Englisch mit deutschen Erklärungen

 

Formel in Zelle

In Zelle und Bearbeitungsleiste sichtbar

In Zelle sichtbar

 

12,5

Wird als Zahl interpretiert

Wird als Text interpretiert

 

Taste Entfernen

funktioniert

funktioniert nicht

 

Trennzeichen

Semikolon

Komma

 

A und B verketten

=VERKETTEN("A";"B")

=CONCAT("A","B")

 

Summe aus C7 und C8

=SUMME(C7;C8)

=SUM(C7,C8)

 

Mittelwert aus C7 und C8

=MITTELWERT(C7;C8)

=AVERAGE(C7,C8)

 

Ist C7 ein Text?

=WENN(ISTTEXT(C7);"Ja";"Nein")

=IF(ISTEXT(C7),"Ja","Nein")

 

 

Bereiche

 

Excel Online Iframe Detection

 

Durch geeignete Formeln lässt sich feststellen, ob eine Datei als Excel Online Iframe geöffnet wurde.

Diese Formeln lassen unterschiedliche Rückgabedatentypen zu.

 

Rückgabedatentyp

Excel Online

Excel Online Iframe

Formel

Zahl

0

1

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));1;0)

Zahl

1

0

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));0;1)

Text

non framing

framing

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"framing";"non framing")

Text

nicht eingebettet

eingebettet

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"eingebettet";"nicht eingebettet")

Text

no

yes

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"yes";"no")

Text

yes

no

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"no";"yes")

Buchstabe

O

I

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"I";"O")

Zwei Buchstaben

EO

EI

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"EI";"EO")

Drei Buchstaben

EOA

EOI

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"EOI";"EOA")

Symbol

-

+

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"+";"-")

Symbol

+

-

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"+";"-")

Tag

#Onl

#Ifr

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));"#Ifr";"#Onl")

Zahl

-1

1

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));1;-1)

Zahl

1

-1

=WENN(ISTFEHLER(TEXT(JETZT();"TT.MM.JJJJ"));-1;1)

 

Bereiche