Nachhilfe

 

 

 

Startseite

Dienstleistungen

Software

Datenschutz

Impressum

 

 

 

 

 

 

 

Excel Formelsammlung

 

Grundlegende und einfache Formeln für die Programmierung

 

In den Beispielen findet die Zelle C7 Verwendung.

Zusätzlich wird Zelle C8 mit einbezogen, wenn es um zwei Parameter geht.

 

 

Bereiche

 

Eine Zahl

Zwei Zahlen

Datum

Uhrzeit

Text

Bedingungen

Prozentrechnung

Promillerechnung

Buchstabe

Wort

Semistabile Zufallszahlen (Seite 02)

Infos (Seite 02)

Formate (Seite 02)

Fest (Seite 02)

Zeichen (Seite 02)

Möglichkeiten der Adressierung (Seite 02)

Iterative Formeln (Seite 02)

Erweiterte Formeln (Fortgeschrittenenbereich)

 

 

Eine Zahl

 

Im Allgemeinen ist der Rückgabedatentyp eine Zahl.

(T) im Kurztext bedeutet, dass der Rückgabedatentyp ein Text ist.

 

Kurztext

Beispielzahl (C7)

Ergebnis

Formel

Zahl ohne Nachkommastellen

8,292

8

=ABRUNDEN(C7;0)

Positive Zahl

-12,5

12,5

=ABS(C7)

Negative Zahl

13,2

-13,2

=-ABS(C7)

Das Doppelte

5,5

11

=C7*2

Die Hälfte

18,2

9,1

=C7/2

Nur die Nachkommastellen

232,817

0,817

=ABS(C7-ABRUNDEN(C7;0))

Nur die Zehntel

312,48736

4

=ABRUNDEN(ABS(C7-ABRUNDEN(C7;0))*10;0)

Nur die Hundertstel

312,48736

8

=ABRUNDEN(ABS(C7-ABRUNDEN(C7;1))*100;0)

Nur die Tausendstel

312,48736

7

=ABRUNDEN(ABS(C7-ABRUNDEN(C7;2))*1000;0)

Nur die Zehntausendstel

312,48736

3

=ABRUNDEN(ABS(C7-ABRUNDEN(C7;3))*10000;0)

Nur die Hunderttausendstel

312,48736

6

=ABRUNDEN(ABS(C7-ABRUNDEN(C7;4))*100000;0)

Nur die Einer

312,48736

2

=ABS(ABRUNDEN(C7;0)-ABRUNDEN(C7;-1))

Nur die Zehner

312,48736

1

=ABS(ABRUNDEN(C7/10;0)-ABRUNDEN(C7/10;-1))

Nur die Hunderter

312,48736

3

=ABS(ABRUNDEN(C7/100;0)-ABRUNDEN(C7/100;-1))

Nur die Tausender

463242,892

3

=ABS(ABRUNDEN(C7/1000;0)-ABRUNDEN(C7/1000;-1))

Nur die Zehntausender

463242,892

6

=ABS(ABRUNDEN(C7/10000;0)-ABRUNDEN(C7/10000;-1))

Nur die Hunderttausender

463242,892

4

=ABS(ABRUNDEN(C7/100000;0)-ABRUNDEN(C7/100000;-1))

Gegenzahl bei Plus

12,5

-12,5

=-C7

Gegenzahl bei Mal

4

0,25

=1/C7

Zahl als Text (T)

12,8

12,8

=VERKETTEN(C7)

Länge der Zahl als Text

12,8

4

=LÄNGE(VERKETTEN(C7))

Komma wegmachen

12,8

128

=WECHSELN(C7;",";"")*1

Komma als Punkt (T)

12,8

12.8

=WECHSELN(VERKETTEN(C7);",";".")

Komma als - (T)

12,8

12-8

=WECHSELN(VERKETTEN(C7);",";"-")

Das Dreifache

100

300

=C7*3

Ein Drittel

18

6

=C7/3

Runden auf Tausendstel

18,4349

18,435

=RUNDEN(C7;3)

Runden auf Hundertstel

18,4349

18,43

=RUNDEN(C7;2)

Runden auf Zehntel

18,4349

18,4

=RUNDEN(C7;1)

Runden auf Einer

18,4349

18

=RUNDEN(C7;0)

Runden auf Zehner

18,4349

20

=RUNDEN(C7;-1)

Runden auf Hunderter

3475,253

3500

=RUNDEN(C7;-2)

Runden auf Tausender

3475,253

3000

=RUNDEN(C7;-3)

Wurzel aus der Zahl

16

4

=WURZEL(C7)

Zahl hoch 2

2

4

=C7^2

Zahl hoch 3

2

8

=C7^3

Zahl hoch 4

2

16

=C7^4

Dritte Wurzel aus der Zahl

343

7

=C7^(1/3)

Vierte Wurzel aus der Zahl

256

4

=C7^(1/4)

e hoch Zahl

1

2,718281828

=EXP(C7)

ln von Zahl

2,718281828

1

=LN(C7)

10 hoch Zahl

4

10000

=10^C7

log von Zahl

10000

4

=LOG(C7)

Zahl als Bruch (T)

5,25

 21 / 4 

=TEXT(C7;"??? / ???")

Zahl als gemischter Bruch (T)

5,25

5   1 / 4 

=TEXT(C7;"### ??? / ???")

Zahl als Bruch (T)

5,25

 21/4 

=TEXT(C7;"???/???")

Zahl als gemischter Bruch (T)

5,25

5   1/4 

=TEXT(C7;"### ???/???")

Sinus der Zahl (Grad)

30

0,5

=SIN(BOGENMASS(C7))

Cosinus der Zahl (Grad)

60

0,5

=COS(BOGENMASS(C7))

Tangens der Zahl (Grad)

45

1

=TAN(BOGENMASS(C7))

Zahl als Römische Zahl

9

IX

=RÖMISCH(C7;0)

Zahl als achtstellige Binärzahl (T)

31

00011111

=DEZINBIN(C7;8)

Zahl als zweistellige Hexadezimalzahl (T)

31

1F

=DEZINHEX(C7;2)

Sinus der Zahl (Bogenmaß)

0

0

=SIN(C7)

Cosinus der Zahl (Bogenmaß)

0

1

=COS(C7)

Tangens der Zahl (Bogenmaß)

3,141592654

-1

=TAN(C7)

Die Zahl Pi

3,141592654

3,141592654

=PI()

Die Eulersche Zahl e

2,718281828

2,718281828

=EXP(1)

Sinus hoch minus 1 (Grad)

0,5

30

=GRAD(ARCSIN(C7))

Cosinus hoch minus 1 (Grad)

0,5

60

=GRAD(ARCCOS(C7))

Tangens hoch minus 1 (Grad)

1

45

=GRAD(ARCTAN(C7))

Grad in Bogenmaß

180

3,141592654

=BOGENMASS(C7)

Bogenmaß in Grad

3,141592654

180

=GRAD(C7)

Fakultät der Zahl

4

24

=FAKULTÄT(C7)

Sinus hoch minus 1 (Bogenmaß)

0

0

=ARCSIN(C7)

Cosinus hoch minus 1 (Bogenmaß)

0

1,570796327

=ARCCOS(C7)

Tangens hoch minus 1 (Bogenmaß)

-1

-0,785398163

=ARCTAN(C7)

 

Bereiche

 

Zwei Zahlen

 

Im Allgemeinen ist der Rückgabedatentyp eine Zahl.

(T) im Kurztext bedeutet, dass der Rückgabedatentyp ein Text ist.

 

Kurztext

Beispielzahlen (C7/C8)

Ergebnis

Formel

C7 + C8

4 und 5

9

=C7+C8

C7 + C8 als Rechnung (T)

4 und 5

4 + 5 = 9

=VERKETTEN(C7;" + ";C8;" = ";C7+C8)

C7 - C8

12 und 7

5

=C7-C8

C7 - C8 als Rechnung (T)

12 und 7

12 - 7 = 5

=VERKETTEN(C7;" - ";C8;" = ";C7-C8)

C8 - C7

3 und 21

18

=C8-C7

C8 - C7 als Rechnung (T)

3 und 21

21 - 3 = 18

=VERKETTEN(C8;" - ";C7;" = ";C8-C7)

C7 mal C8

4 und 5

20

=C7*C8

C7 mal C8 als Rechnung (T)

4 und 5

4 * 5 = 20

=VERKETTEN(C7;" * ";C8;" = ";C7*C8)

C7 geteilt durch C8

63 und 9

7

=C7/C8

C7 geteilt durch C8 als Rechnung (T)

63 und 9

63 : 9 = 7

=VERKETTEN(C7;" : ";C8;" = ";C7/C8)

C8 geteilt durch C7

63 und 630

10

=C8/C7

C8 geteilt durch C7 als Rechnung (T)

63 und 630

630 : 63 = 10

=VERKETTEN(C8;" : ";C7;" = ";C8/C7)

Mitte der beiden Zahlen

15 und 111

63

=(C7+C8)/2

C7 hoch C8

2 und 3

8

=C7^C8

C8 hoch C7

2 und 3

9

=C8^C7

C7te Wurzel aus C8

4 und 16

2

=C8^(1/C7)

C8te Wurzel aus C7

1000 und 3

10

=C7^(1/C8)

Summe der Beträge

-4 und -8

12

=ABS(C7)+ABS(C8)

Betrag der Differenz der Beträge

-4 und -8

4

=ABS(ABS(C7)-ABS(C8))

Größter Gemeinsamer Teiler

48 und 60

12

=GGT(C7;C8)

Kleinstes Gemeinsames Vielfaches

48 und 60

240

=KGV(C7;C8)

Geteilt mit Rest, C7 durch C8 (T)

55 und 3

18 Rest 1

=VERKETTEN(ABRUNDEN(C7/C8;0);" Rest ";REST(C7;C8))

Geteilt mit Rest, C8 durch C7 (T)

12 und 363

30 Rest 3

=VERKETTEN(ABRUNDEN(C8/C7;0);" Rest ";REST(C8;C7))

Vorgänger von C7

87 und C8

86

=C7-1

Nachfolger von C8

C7 und 109

110

=C8+1

C7 / C8 als Bruch (T)

5 und 17

5 / 17

=VERKETTEN(C7;" / ";C8)

C8 / C7 als Bruch (T)

23 und 11

11 / 23

=VERKETTEN(C8;" / ";C7)

C7 / C8 als Punkt (T)

3 und -2

P (3/-2)

=VERKETTEN("P (";C7;"/";C8;")")

C8 / C7 als Punkt (T)

3 und -2

P (-2/3)

=VERKETTEN("P (";C8;"/";C7;")")

 

Bereiche

 

Datum

 

Im Allgemeinen ist der Rückgabedatentyp ein Datum.

(T) im Kurztext bedeutet, dass der Rückgabedatentyp ein Text ist.

(Z) im Kurztext bedeutet, dass der Rückgabedatentyp eine Zahl ist.

 

Kurztext

Beispieldatum (C7)

Beispielergebnis

Formel

Heute

-

28.12.2019

=HEUTE()

Gestern

-

27.12.2019

=HEUTE()-1

Vorgestern

-

26.12.2019

=HEUTE()-2

Vorvorgestern

-

25.12.2019

=HEUTE()-3

Morgen

-

29.12.2019

=HEUTE()+1

Übermorgen

-

30.12.2019

=HEUTE()+2

Überübermorgen

-

31.12.2019

=HEUTE()+3

Heute in einer Woche

-

04.01.2020

=HEUTE()+7

Heute in 14 Tagen

-

11.01.2020

=HEUTE()+14

Heute vor einer Woche

-

21.12.2019

=HEUTE()-7

Heute vor 14 Tagen

-

14.12.2019

=HEUTE()-14

Aktueller Wochentag (T)

-

Samstag

=TEXT(WOCHENTAG(HEUTE();1);"TTTT")

Gestriger Wochentag (T)

-

Freitag

=TEXT(WOCHENTAG(HEUTE()-1;1);"TTTT")

Morgiger Wochentag (T)

-

Sonntag

=TEXT(WOCHENTAG(HEUTE()+1;1);"TTTT")

Aktueller Wochentag (T) kurz

-

Sa

=TEXT(WOCHENTAG(HEUTE();1);"TTT")

Gestriger Wochentag (T) kurz

-

Fr

=TEXT(WOCHENTAG(HEUTE()-1;1);"TTT")

Morgiger Wochentag (T) kurz

-

So

=TEXT(WOCHENTAG(HEUTE()+1;1);"TTT")

Aktueller Wochentag (T) aus Liste

-

Samstag

=WAHL(WOCHENTAG(HEUTE();2);"Montag";…;"Sonntag")

Aktueller Wochentag (T) aus Liste

-

Saturday

=WAHL(WOCHENTAG(HEUTE();2);"Monday";…;"Sunday")

Aktueller Wochentag (T) aus Liste

-

sábado

=WAHL(WOCHENTAG(HEUTE();2);"lunes";…;"domingo")

Schon … Tage seit dem … (Z)

01.01.2019

361

=HEUTE()-C7

Noch … Tage bis zum … (Z)

01.01.2020

4

=C7-HEUTE()

Aktuelle Kalenderwoche (Z)

-

52

=KALENDERWOCHE(HEUTE();1)

Aktueller Tag (1 bis 31) (Z)

-

28

=TAG(HEUTE())

Aktueller Monat (1 bis 12) (Z)

-

12

=MONAT(HEUTE())

Aktueller Monatsname (T)

-

Dezember

=TEXT(HEUTE();"MMMM")

Aktueller Monatsname (T) kurz

-

Dez

=TEXT(HEUTE();"MMM")

Aktuelles Jahr (Z)

-

2019

=JAHR(HEUTE())

Nachfolgedatum von C7

03.04.2019

04.04.2019

=C7+1

Vorangegangenes Datum von C7

03.04.2019

02.04.2019

=C7-1

C7 im Format Jahr - Monat - Tag (T)

03.04.2019

2019 - 04 - 03

=TEXT(C7;"JJJJ - MM - TT")

C7 im Format Jahr - Monatsname - Tag (T)

03.04.2019

2019 - April - 03

=TEXT(C7;"JJJJ - MMMM - TT")

C7 im Format Jahr - Tag - Monat (T)

03.04.2019

2019 - 03 - 04

=TEXT(C7;"JJJJ - TT - MM")

C7 im Format Jahr - Tag - Monatsname (T)

03.04.2019

2019 - 03 - April

=TEXT(C7;"JJJJ - TT - MMMM")

 

Bereiche

 

Uhrzeit

 

Im Allgemeinen ist der Rückgabedatentyp eine Uhrzeit.

(T) im Kurztext bedeutet, dass der Rückgabedatentyp ein Text ist.

(Z) im Kurztext bedeutet, dass der Rückgabedatentyp eine Zahl ist.

 

Kurztext

Beispieluhrzeit (C7)

Beispielergebnis

Formel

Jetzt (T)

-

19:15

=TEXT(JETZT()-HEUTE();"hh:mm")

Jetzt (T)

-

19:15:55

=TEXT(JETZT()-HEUTE();"hh:mm:ss")

Jetzt (T)

-

< 19:16 >

=TEXT(JETZT()-HEUTE();"< hh:mm >")

Jetzt (T)

-

< 19:17:14 >

=TEXT(JETZT()-HEUTE();"< hh:mm:ss >")

Jetzt (T)

-

Uhrzeit 19:18

=VERKETTEN("Uhrzeit ";TEXT(JETZT()-HEUTE();"hh:mm"))

Jetzt (T)

-

Es ist 19:18 Uhr.

=VERKETTEN("Es ist ";TEXT(JETZT()-HEUTE();"hh:mm");" Uhr.")

Jetzt

-

19:19

=JETZT()-HEUTE()

Aktuelle Minute (Z)

-

21

=MINUTE(JETZT()-HEUTE())

Aktuelle Stunde (Z)

-

19

=STUNDE(JETZT()-HEUTE())

Noch … Minuten bis um …

20:00

0:36

=C7-(JETZT()-HEUTE())

Noch … Minuten bis um … (T)

20:00

35

=TEXT(C7-(JETZT()-HEUTE());"mm")

Noch … Minuten bis um … (Z)

20:00

33

=TEXT(C7-(JETZT()-HEUTE());"mm")*1

Noch … Stunden und Minuten bis um … (T)

23:15

03:45

=TEXT(C7-(JETZT()-HEUTE());"hh:mm")

Noch … Stunden bis um … (Z)

23:15

3,7

=TEXT(C7-(JETZT()-HEUTE());"hh:mm")*24

 

Bereiche

 

Text

 

Im Allgemeinen ist der Rückgabedatentyp ein Text.

(Z) im Kurztext bedeutet, dass der Rückgabedatentyp eine Zahl ist.

 

Kurztext

Beispieltext (C7)

Ergebnis

Formel

Tel.:

0231 / 00xx

Tel.: 0231 / 00xx

=VERKETTEN("Tel.: ";C7)

Tel.

0231 / 00xx

Tel. 0231 / 00xx

=VERKETTEN("Tel. ";C7)

Telefon

0231 / 00xx

Telefon 0231 / 00xx

=VERKETTEN("Telefon ";C7)

Mail:

max@mix.max

Mail: max@mix.max

=VERKETTEN("Mail: ";C7)

Vorname:

Peter

Vorname: Peter

=VERKETTEN("Vorname: ";C7)

Nachname:

Schmidt

Nachname: Schmidt

=VERKETTEN("Nachname: ";C7)

Name:

Udo Ibra

Name: Udo Ibra

=VERKETTEN("Name: ";C7)

Straße:

Tanis 8a

Straße: Tanis 8a

=VERKETTEN("Straße: ";C7)

PLZ:

684xx

PLZ: 684xx

=VERKETTEN("PLZ: ";C7)

Postleitzahl:

684xx

Postleitzahl: 684xx

=VERKETTEN("Postleitzahl: ";C7)

Beruf:

Optiker

Beruf: Optiker

=VERKETTEN("Beruf: ";C7)

Namen anpassen

peter schmidt

Peter Schmidt

=GROSS2(C7)

Straße anpassen

am lindenhof     12

Am Lindenhof 12

=SÄUBERN(GLÄTTEN(GROSS2(C7)))

Emailadresse anpassen

max @miX. mAx

max@mix.max

=WECHSELN(SÄUBERN(GLÄTTEN(KLEIN(C7)));" ";"")

Webseite anpassen

http://www. Hfxx . Com

http://www.hfxx.com

=WECHSELN(SÄUBERN(GLÄTTEN(KLEIN(C7)));" ";"")

Ort anpassen

BorDERsteDt

Borderstedt

=WECHSELN(SÄUBERN(GLÄTTEN(GROSS2(C7)));" ";"")

Textlänge (Z)

Wir sind in London.

19

=LÄNGE(C7)

Anzahl der Leerzeichen (Z)

Wir sind in London.

3

=LÄNGE(C7)-LÄNGE(WECHSELN(C7;" ";""))

Textmarke # nach erstem Wort

Wir sind in London.

Wir#sind in London.

=WECHSELN(C7;" ";"#";1)

Textmarke # nach zweitem Wort

Wir sind in London.

Wir sind#in London.

=WECHSELN(C7;" ";"#";2)

Textmarke # nach drittem Wort

Wir sind in London.

Wir sind in#London.

=WECHSELN(C7;" ";"#";3)

Zeilenumbruch

-

Wir
sind.

=VERKETTEN("Wir";ZEICHEN(10);"sind.")

Zeichen (Z)

0

48

=CODE(C7)

Zeichen (Z)

9

57

=CODE(C7)

Zeichen (Z)

A

65

=CODE(C7)

Zeichen (Z)

Z

90

=CODE(C7)

Zeichen (Z)

a

97

=CODE(C7)

Zeichen (Z)

z

122

=CODE(C7)

 

Bereiche

 

Bedingungen

 

Im Allgemeinen ist der Rückgabedatentyp ein Text.

(Z) im Kurztext bedeutet, dass der Rückgabedatentyp eine Zahl ist.

 

Kurztext

Zellinhalt (C7)

Ergebnis

Formel

Zahl größer als Null

12

Ja

=WENN(UND(ISTZAHL(C7);C7>0);"Ja";"Nein")

Zahl größer als Null

-4

Nein

=WENN(UND(ISTZAHL(C7);C7>0);"Ja";"Nein")

Zahl größer als Null

-

Nein

=WENN(UND(ISTZAHL(C7);C7>0);"Ja";"Nein")

Zahl kleiner als Null

12

Nein

=WENN(UND(ISTZAHL(C7);C7<0);"Ja";"Nein")

Zahl kleiner als Null

-4

Ja

=WENN(UND(ISTZAHL(C7);C7<0);"Ja";"Nein")

Zahl kleiner als Null

-

Nein

=WENN(UND(ISTZAHL(C7);C7<0);"Ja";"Nein")

Leer

22

Nein

=WENN(C7="";"Ja";"Nein")

Leer

=""

Ja

=WENN(C7="";"Ja";"Nein")

Leer

-

Ja

=WENN(C7="";"Ja";"Nein")

Leer

Peter Schmidt

Nein

=WENN(C7="";"Ja";"Nein")

Nicht leer

kxk

Ja

=WENN(C7<>"";"Ja";"Nein")

Nicht leer

-

Nein

=WENN(C7<>"";"Ja";"Nein")

Nicht leer

-12

Ja

=WENN(C7<>"";"Ja";"Nein")

Nicht leer

abc

Ja

=WENN(C7<>"";"Ja";"Nein")

Zelle C7 enthält einen Fehler

-12

Nein

=WENN(ISTFEHLER(C7);"Ja";"Nein")

Zelle C7 enthält einen Fehler

abc

Nein

=WENN(ISTFEHLER(C7);"Ja";"Nein")

Zelle C7 enthält einen Fehler

=1/0

Ja

=WENN(ISTFEHLER(C7);"Ja";"Nein")

Zelle C7 enthält einen Fehler

#DIV/0!

Ja

=WENN(ISTFEHLER(C7);"Ja";"Nein")

Zelle C7 enthält einen Fehler

#WERT!

Ja

=WENN(ISTFEHLER(C7);"Ja";"Nein")

Zelle C7 enthält einen Fehler

#NV

Ja

=WENN(ISTFEHLER(C7);"Ja";"Nein")

C7 beginnt mit Buchstaben

Antonia

Ja

=WENN(UND(LINKS(C7;1)>="A";LINKS(C7;1)<="Z");"Ja";"Nein")

C7 beginnt mit Buchstaben

12

Nein

=WENN(UND(LINKS(C7;1)>="A";LINKS(C7;1)<="Z");"Ja";"Nein")

C7 beginnt mit Buchstaben

sandig

Ja

=WENN(UND(LINKS(C7;1)>="A";LINKS(C7;1)<="Z");"Ja";"Nein")

C7 beginnt mit Buchstaben

-

Nein

=WENN(UND(LINKS(C7;1)>="A";LINKS(C7;1)<="Z");"Ja";"Nein")

Zahl größer als Null (Z)

12

1

=WENN(UND(ISTZAHL(C7);C7>0);1;0)

Zahl größer als Null (Z)

-4

0

=WENN(UND(ISTZAHL(C7);C7>0);1;0)

Zahl größer als Null (Z)

-

0

=WENN(UND(ISTZAHL(C7);C7>0);1;0)

 

Bereiche

 

Prozentrechnung

 

Im Allgemeinen ist der Rückgabedatentyp eine Zahl oder eine Währungsangabe.

 

Kurztext

Begriffe

Ergebnis / Werte

Formel

Prozentwert berechnen

Resultat >

30

=C7/100*C8

C7 >

Grundwert >

250

 

C8 >

Prozentsatz >

12

 

Prozentsatz berechnen

Resultat >

12

=C8/C7*100

C7 >

Grundwert >

250

 

C8 >

Prozentwert >

30

 

Grundwert berechnen

Resultat >

250

=C7/C8*100

C7 >

Prozentwert >

30

 

C8 >

Prozentsatz >

12

 

Bruttopreis berechnen

Resultat >

238,00 €

=C7/100*(100+C8)

C7 >

Nettopreis >

200,00 €

 

C8 >

Umsatzsteuersatz >

19

 

Nettopreis berechnen

Resultat >

200,00 €

=C7/(100+C8)*100

C7 >

Bruttopreis >

238,00 €

 

C8 >

Umsatzsteuersatz >

19

 

Umsatzsteueranteil berechnen

Resultat >

38,00 €

=C7-C8

C7 >

Bruttopreis >

238,00 €

 

C8 >

Nettopreis >

200,00 €

 

Umsatzsteuersatz berechnen

Resultat >

19

=C7/C8*100-100

C7 >

Bruttopreis >

238,00 €

 

C8 >

Nettopreis >

200,00 €

 

 

Bereiche

 

Promillerechnung

 

Im Allgemeinen ist der Rückgabedatentyp eine Zahl.

 

Kurztext

Begriffe

Ergebnis / Werte

Formel

Promillewert berechnen

Resultat >

3

=C7/1000*C8

C7 >

Grundwert >

250

 

C8 >

Promillesatz >

12

 

Promillesatz berechnen

Resultat >

12

=C8/C7*1000

C7 >

Grundwert >

250

 

C8 >

Promillewert >

3

 

Grundwert berechnen

Resultat >

250

=C7/C8*1000

C7 >

Promillewert >

3

 

C8 >

Promillesatz >

12

 

 

Bereiche

 

Buchstabe

 

Im Allgemeinen ist der Rückgabedatentyp ein Text.

 

Kurztext

Beispielbuchstabe (C7)

Ergebnis

Formel

Nachfolger

D

E

=ZEICHEN(CODE(C7)+1)

Vorgänger

H

G

=ZEICHEN(CODE(C7)-1)

Kleinbuchstabe wird Großbuchstabe

e

E

=ZEICHEN(CODE(C7)-32)

Großbuchstabe wird Kleinbuchstabe

C

c

=ZEICHEN(CODE(C7)+32)

Test auf Großbuchstabe

X

Ja

=WENN(UND(CODE(C7)>=65;CODE(C7)<=90);"Ja";"Nein")

Test auf Großbuchstabe

m

Nein

=WENN(UND(CODE(C7)>=65;CODE(C7)<=90);"Ja";"Nein")

Test auf Großbuchstabe

245,283

Nein

=WENN(UND(CODE(C7)>=65;CODE(C7)<=90);"Ja";"Nein")

Test auf Großbuchstabe

-

#WERT!

=WENN(UND(CODE(C7)>=65;CODE(C7)<=90);"Ja";"Nein")

Test auf Kleinbuchstabe

d

Ja

=WENN(UND(CODE(C7)>=97;CODE(C7)<=122);"Ja";"Nein")

Test auf Kleinbuchstabe

M

Nein

=WENN(UND(CODE(C7)>=97;CODE(C7)<=122);"Ja";"Nein")

Test auf Kleinbuchstabe

245,283

Nein

=WENN(UND(CODE(C7)>=97;CODE(C7)<=122);"Ja";"Nein")

Test auf Kleinbuchstabe

-

#WERT!

=WENN(UND(CODE(C7)>=97;CODE(C7)<=122);"Ja";"Nein")

Buchstaben wiederholen (2x)

N

NN

=WIEDERHOLEN(C7;2)

Buchstaben wiederholen (3x)

N

NNN

=WIEDERHOLEN(C7;3)

Buchstaben wiederholen (4x)

N

NNNN

=WIEDERHOLEN(C7;4)

Großbuchstabe von G bis P?

G

Ja

=WENN(UND(CODE(C7)>=71;CODE(C7)<=80);"Ja";"Nein")

Großbuchstabe von G bis P?

J

Ja

=WENN(UND(CODE(C7)>=71;CODE(C7)<=80);"Ja";"Nein")

Großbuchstabe von G bis P?

P

Ja

=WENN(UND(CODE(C7)>=71;CODE(C7)<=80);"Ja";"Nein")

Großbuchstabe von G bis P?

F

Nein

=WENN(UND(CODE(C7)>=71;CODE(C7)<=80);"Ja";"Nein")

Großbuchstabe von G bis P?

Q

Nein

=WENN(UND(CODE(C7)>=71;CODE(C7)<=80);"Ja";"Nein")

Großbuchstabe von G bis P?

12,3

Nein

=WENN(UND(CODE(C7)>=71;CODE(C7)<=80);"Ja";"Nein")

Großbuchstabe von G bis P?

-

#WERT!

=WENN(UND(CODE(C7)>=71;CODE(C7)<=80);"Ja";"Nein")

Kleinbuchstabe von g bis p?

g

Ja

=WENN(UND(CODE(C7)>=103;CODE(C7)<=112);"Ja";"Nein")

Kleinbuchstabe von g bis p?

j

Ja

=WENN(UND(CODE(C7)>=103;CODE(C7)<=112);"Ja";"Nein")

Kleinbuchstabe von g bis p?

p

Ja

=WENN(UND(CODE(C7)>=103;CODE(C7)<=112);"Ja";"Nein")

Kleinbuchstabe von g bis p?

f

Nein

=WENN(UND(CODE(C7)>=103;CODE(C7)<=112);"Ja";"Nein")

Kleinbuchstabe von g bis p?

q

Nein

=WENN(UND(CODE(C7)>=103;CODE(C7)<=112);"Ja";"Nein")

Kleinbuchstabe von g bis p?

12,3

Nein

=WENN(UND(CODE(C7)>=103;CODE(C7)<=112);"Ja";"Nein")

Kleinbuchstabe von g bis p?

-

#WERT!

=WENN(UND(CODE(C7)>=103;CODE(C7)<=112);"Ja";"Nein")

Buchstabe mit Anführungszeichen

C

"C"

=VERKETTEN(ZEICHEN(34);C7;ZEICHEN(34))

Buchstabe mit Minuszeichen

T

-T-

=VERKETTEN("-";C7;"-")

<Buchstabe>

h

<h>

=VERKETTEN("<";C7;">")

 

Bereiche

 

Wort

 

Im Allgemeinen ist der Rückgabedatentyp ein Text.

(Z) im Kurztext bedeutet, dass der Rückgabedatentyp eine Zahl ist.

 

Kurztext

Beispielwort (C7)

Ergebnis

Formel

Erster Buchstabe

London

L

=TEIL(C7;1;1)

Zweiter Buchstabe

London

o

=TEIL(C7;2;1)

Dritter Buchstabe

London

n

=TEIL(C7;3;1)

Vierter Buchstabe

London

d

=TEIL(C7;4;1)

Fünfter Buchstabe

London

o

=TEIL(C7;5;1)

Sechster Buchstabe

London

n

=TEIL(C7;6;1)

Erster Buchstabe von rechts

Sam

m

=TEIL(C7;LÄNGE(C7);1)

Zweiter Buchstabe von rechts

Sam

a

=TEIL(C7;LÄNGE(C7)-1;1)

Dritter Buchstabe von rechts

Sam

S

=TEIL(C7;LÄNGE(C7)-2;1)

Länge des Wortes (Z)

London

6

=LÄNGE(C7)

Länge des Wortes (Z)

Sam

3

=LÄNGE(C7)

Länge des Wortes (Z)

Blau

4

=LÄNGE(C7)

Test auf Beginn mit Großbuchstabe

Blau

Ja

=WENN(UND(CODE(C7)>=65;CODE(C7)<=90);"Ja";"Nein")

Test auf Beginn mit Großbuchstabe

laufen

Nein

=WENN(UND(CODE(C7)>=65;CODE(C7)<=90);"Ja";"Nein")

Test auf Beginn mit Kleinbuchstabe

laufen

Ja

=WENN(UND(CODE(C7)>=97;CODE(C7)<=122);"Ja";"Nein")

Test auf Beginn mit Kleinbuchstabe

Blau

Nein

=WENN(UND(CODE(C7)>=97;CODE(C7)<=122);"Ja";"Nein")

Erster Buchstabe G bis P?

Wir

Nein

=WENN(UND(CODE(C7)>=71;CODE(C7)<=80);"Ja";"Nein")

Erster Buchstabe G bis P?

Haus

Ja

=WENN(UND(CODE(C7)>=71;CODE(C7)<=80);"Ja";"Nein")

Erster Buchstabe von g bis p?

gehen

Ja

=WENN(UND(CODE(C7)>=103;CODE(C7)<=112);"Ja";"Nein")

Erster Buchstabe von g bis p?

schreiben

Nein

=WENN(UND(CODE(C7)>=103;CODE(C7)<=112);"Ja";"Nein")

Wort:

schreiben

Wort: Sam

=VERKETTEN("Wort: ";C7)

Das Wort ist "…".

Sam

Das Wort ist "Sam".

=VERKETTEN("Das Wort ist ";ZEICHEN(34);C7;ZEICHEN(34);".")

Wort wiederholen (2x)

Wort

WortWort

=WIEDERHOLEN(C7;2)

Wort wiederholen (3x)

Text

TextTextText

=WIEDERHOLEN(C7;3)

Wort wiederholen (4x)

="Tag "

Tag Tag Tag Tag

=WIEDERHOLEN(C7;4)

 

Bereiche